Back to overview
Degraded
One of our China's nodes is down
Jul 11 at 02:05pm HDT
Resolved
Jul 12 at 07:29am HDT
All nodes in China are operational now.
Affected services
Created
Jul 11 at 02:05pm HDT
One of our nodes in China is down due to an outage from the provider side. We're still working on recovering it.
Affected services